#1042

89ouki
参加者

ペイデザイン(現スタップペイメント)から、以下のようなアドバイスを受けました。

弊社決済プラグイン内に「WooCommerce For Japan」の一部ファイルを抜粋したものが含まれており、このファイルの
バージョンが古いため「WooCommerce For Japan」の設定画面に影響が出ているようです。

下記に示す1ファイルを複製元から複製先へコピーすることで、とりあえず問題は回避できるかと思います。
※コピーを行う前に複製先のオリジナルファイルのバックアップを必ず取得していただけますようお願いいたします。

複製元
./wp-content/plugins/woocommerce-for-japan/includes/wc4jp-framework/class-wc4jp-setting.php

複製先
./wp-content/plugins/woo-paydesign/includes/wc4jp-framework/class-wc4jp-setting.php

以上、ご参考まで。
ちなみに私は正直「?」な内容で、ファイルをいじるのも怖いので対処していません。